System Requirements

From Brave Frontier 2 Wiki
Jump to: navigation, search

This article is a stub. You can help Brave Frontier 2 Wiki by expanding it.

The following are the minimum and recommended system requirements for Brave Frontier 2.

Requirements[edit | edit source]

See also[edit | edit source]